System Slow Down

Incident Report for SendSmart

Resolved

This incident has been resolved.
Posted Sep 01, 2025 - 13:30 PDT

Identified

One of the servers is working slow today. We are aware and investigating this.
Posted Sep 01, 2025 - 07:45 PDT
This incident affected: SendSmart Servers.